Frequent Questions

Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home/cblctrl/public_html/faq.php on line 35
PROBLEM SOLUTION TO PROBLEM

If you have to turn your knob to 100 or more for grinder to work Plug box directly into switch pigtail. Check grinder, if it works, OK, its your cord. If it doesn't, check wiring in your Control Kit plugs. Go to solution 6 for wire diagram. If the connections are OK then take the back off of box. Reverse black and white wire on Rheostat. Also recheck your blue scotch lock on green wire to make sure its clipped into the wire.

Rheostat works but grinder doesn't. Breaker is either burnt up or the blue scotch lock connector under the hood that you connected the green wire to factory ground has come apart or burnt up.

I burnt up my Rheostat when I changed plugs. When replacing a plug on our 200 units, did you put the white wire on green screw, preen wire on silver screw and black wire on brass screw. On all 200 D's T.L. plug, the black wire goes to the Y screw - green wire to X screw and white wire to silver screw. On 300 D male T.L. plug, that goes into welding machine, put the red wire on Y screw and green wire on silver screw.

Grinder works but Rheostat will not register but Rheostat in welding machine does work. The white wire is broken between the welding machine and box somewhere. On your extension cord it could be the green wire, but on the box pigtail it will be the white wire SUGGESTION; plug your box directly into short pigtail hanging from your machine and try your grinder. If it works a wire is broken in your extension cord.

Switch complaints, (single pole, double throw) Your switch should not be moved with machine running. It is not moisture proof. It's a slide bar and has a 55 DC amperage rating and it has a center OFF position.

Remote gets awful hot: Check female plug on extension cord. May have arc inside when unplugging box from extension cord with welding machine running. Also could be a loose connection in plugs or inside of box. Don't lay box on its back because it will stop flow of air. Also check the RPMs on your welding machine. If they're to high it will cause box to run hot. RPMs should be 1550 high idle, no load.

Burnt up switch: Until you can get another switch, transfer the white wire on switch to center screw on switch. Control on Remote only.

© Copyright 2018 Cable Control Kits. All Rights Reserved.